Skip to main content
← All vulnerabilities
CVE-2022-1428

An issue has been discovered in GitLab affecting all versions before 14.8.6, all versions starting from 14.9 before 14.9.4, all versions sta

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 14.8.6, 14.9.4, 14.10.1
None on Exploit-DB, Metasploit or GitHub

Summary

An issue has been discovered in GitLab affecting all versions before 14.8.6, all versions starting from 14.9 before 14.9.4, all versions starting from 14.10 before 14.10.1. GitLab was incorrectly verifying throttling limits for authenticated package requests which resulted in limits not being enforced.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • GitLab GitLab

    fixed in 14.8.6; From 14.9 · fixed in 14.9.4; From 14.10 · fixed in 14.10.1

References 2

gitlab.com