Skip to main content
← All vulnerabilities
CVE-2022-1417

Improper access control in GitLab CE/EE affecting all versions starting from 8.12 before 14.8.6, all versions starting from 14.9 before 14.9

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 14.8.6, 14.9.4, 14.10.1
None on Exploit-DB, Metasploit or GitHub

Summary

Improper access control in GitLab CE/EE affecting all versions starting from 8.12 before 14.8.6, all versions starting from 14.9 before 14.9.4, and all versions starting from 14.10 before 14.10.1 allows non-project members to access contents of Project Members-only Wikis via malicious CI jobs

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • GitLab GitLab

    From 8.12 · fixed in 14.8.6; From 14.9 · fixed in 14.9.4; From 14.10 · fixed in 14.10.1

References 3

gitlab.com

hackerone.com