Skip to main content
← All vulnerabilities
CVE-2022-1406

Improper input validation in GitLab CE/EE affecting all versions from 8.12 prior to 14.8.6, all versions from 14.9.0 prior to 14.9.4, and 14

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 14.10.1, 14.9.4, 14.8.6
None on Exploit-DB, Metasploit or GitHub

Summary

Improper input validation in GitLab CE/EE affecting all versions from 8.12 prior to 14.8.6, all versions from 14.9.0 prior to 14.9.4, and 14.10.0 allows a Developer to read protected Group or Project CI/CD variables by importing a malicious project

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • GitLab GitLab

    From 14.10.0 · fixed in 14.10.1; From 14.9.0 · fixed in 14.9.4; From 8.12.0 · fixed in 14.8.6

References 3

gitlab.com

hackerone.com