Skip to main content
← All vulnerabilities
CVE-2022-1190

Improper handling of user input in GitLab CE/EE versions 8.3 prior to 14.7.7, 14.8 prior to 14.8.5, and 14.9 prior to 14.9.2 allowed an atta

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 14.7.7, 14.8.5, 14.9.2
None on Exploit-DB, Metasploit or GitHub

Summary

Improper handling of user input in GitLab CE/EE versions 8.3 prior to 14.7.7, 14.8 prior to 14.8.5, and 14.9 prior to 14.9.2 allowed an attacker to exploit a stored XSS by abusing multi-word milestone references in issue descriptions, comments, etc.

Timeline

  1. CVE published
  2. Record last updated
  3. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • GitLab GitLab

    From 8.3.0 · fixed in 14.7.7; From 14.8.0 · fixed in 14.8.5; From 14.9.0 · fixed in 14.9.2

References 3

gitlab.com

hackerone.com