CVE-2022-0538GHSA-34WX-X2W9-VQM3BIT-JENKINS-2022-0538
Jenkins 2.333 and earlier, LTS 2.319.2 and earlier defines custom XStream converters that have not been updated to apply the protections for
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.334, 2.319.3
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Jenkins 2.333 and earlier, LTS 2.319.2 and earlier defines custom XStream converters that have not been updated to apply the protections for the vulnerability CVE-2021-43859 and allow unconstrained resource usage.
Timeline
- CVE published
- Record last updated
Affected versions
- Jenkins project Jenkins
through 2.333; through LTS 2.319.2
- org.jenkins-ci.main:jenkins-coreMaven
From 2.320 · fixed in 2.334
- org.jenkins-ci.main:jenkins-coreMaven
fixed in 2.319.3