Skip to main content
← All vulnerabilities
CVE-2022-0477

An issue has been discovered in GitLab affecting all versions starting from 11.9 before 14.5.4, all versions starting from 14.6.0 before 14.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 14.5.4, 14.6.4, 14.7.1
None on Exploit-DB, Metasploit or GitHub

Summary

An issue has been discovered in GitLab affecting all versions starting from 11.9 before 14.5.4, all versions starting from 14.6.0 before 14.6.4, all versions starting from 14.7.0 before 14.7.1. GitLab was not correctly handling bulk requests to delete existing packages from the package registries which could result in a Denial of Service under specific conditions.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • GitLab GitLab

    From 11.9 · fixed in 14.5.4; From 14.6.0 · fixed in 14.6.4; From 14.7.0 · fixed in 14.7.1

References 2

gitlab.com