Skip to main content
← All vulnerabilities
CVE-2022-0334GHSA-93PJ-4P65-QMR9BIT-MOODLE-2022-0334

A flaw was found in Moodle in versions 3.11 to 3.11.4, 3.10 to 3.10.8, 3.9 to 3.9.11 and earlier unsupported versions.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.11.5, 3.10.8, 3.9.11
None on Exploit-DB, Metasploit or GitHub

Summary

A flaw was found in Moodle in versions 3.11 to 3.11.4, 3.10 to 3.10.8, 3.9 to 3.9.11 and earlier unsupported versions. Insufficient capability checks could lead to users accessing their grade report for courses where they did not have the required gradereport/user:view capability.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a moodle

    Version range not reported

  • moodle/moodlePackagist

    From 3.11 · fixed in 3.11.5

  • moodle/moodlePackagist

    From 3.10 · fixed in 3.10.8

  • moodle/moodlePackagist

    fixed in 3.9.11

References 2

bugzilla.redhat.com

moodle.org