CVE-2022-0333GHSA-M434-M5PV-P35WBIT-MOODLE-2022-0333
A flaw was found in Moodle in versions 3.11 to 3.11.4, 3.10 to 3.10.8, 3.9 to 3.9.11 and earlier unsupported versions.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 3.11.5, 3.10.8, 3.9.11
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
A flaw was found in Moodle in versions 3.11 to 3.11.4, 3.10 to 3.10.8, 3.9 to 3.9.11 and earlier unsupported versions. The calendar:manageentries capability allowed managers to access or modify any calendar event, but should have been restricted from accessing user level events.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a moodle
Version range not reported
- moodle/moodlePackagist
From 3.11 · fixed in 3.11.5
- moodle/moodlePackagist
From 3.10 · fixed in 3.10.8
- moodle/moodlePackagist
From 3.9 · fixed in 3.9.11